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Documentation Information 
This section describes the conventions and revision history of this document.  

Conventions 
Icon 

Icon Description  

Tip  Indicates information that can help you make better use of your product. 

Note Indicates references that can further describe the related topics.  

Caution Indicates situations that could cause data loss or equipment damage.  

Warning Indicates situations that could cause minor personal injury.  

Danger Indicates situations that could cause major personal injury or even death.  

 

Notation 

Notation Description  

Bold 
The text in boldface denotes the name of a hardware button or a software interface element. 

For example, press the PTT key. 

-> 
The symbol directs you to access a multi-level menu. For example, to select “New” from the 

“File” menu, we will describe it as follows: File -> New. 

 

Revision History 
Version  Release Date Description  

R8.5 August 2017 

 Added BT Indoor Positioning section to introduce the feature 

configuration and operation. 

 Added BT Firmware Upgrade section to introduce the feature 

operation. 

 Added manual match feature for PD98X and X1p when using the 

BT call feature. 

R8.0 October 2016 
Added the sections as follows: 

 PD98X / X1p: To introduce how to configure the BT feature and 
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Version  Release Date Description  

how to connect the radio with the BT audio accessory. 

 PD6 and PD7 series: To introduce how to connect the radio with 

the BT audio accessory. 

 BT Programming: To introduce how to wirelessly program the 

radio by the BT dongle. 

 BT API: To introduce the BT API for DMR radios. 

 Abbreviations: To explain the abbreviations in this manual. 

R5.0 December 2012 Initial release. 
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1. Overview 
1.1 Introduction 
BT is a kind of wireless technology that supports short-distance (generally within 10m) communications between 

devices. The BT feature enables the radio to wirelessly exchange information with the BT devices, such as 

wireless ring PTT, wireless earphone, wireless remote speaker microphone, BT beacon, PC etc. The technology 

effectively simplifies radio operations and greatly enriches radio applications. 

The BT feature of DMR radios is mainly applied in the following four aspects: 

 BT Call: Transmit or receive the call through BT audio accessory. 

 BT Programming: Program the radio wirelessly. 

 BT Indoor Positioning: Position the indoor radios real time, and help radio users timely respond the 

dispatching order. 

 BT API: Provide third party with API for more wireless applications. 

Meanwhile, the BT firmware can be upgraded via third-party software to fix bugs and improve the performance. 

1.2 Application Scope 
Different radios support different BT features. 

Model Feature 

PD98X 

BT Call 

BT Programming 

BT Indoor Positioning 

BT Firmware Upgrade 

BT API 

X1p and X1e 
BT Call 

BT Firmware Upgrade 

PD6 and PD7 Series 
BT Call (transmit or receive the call through external 

BT audio accessory) 

1.3 Application Protocols 
The BT module of PD98X, X1p and X1e supports following protocols. 

 BT Protocol (X1p and X1e: V2.1+ EDR; PD98X: V4.0) 
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 HFP 

 SPP 

1.4 Versions 
 R8.5: Added BT indoor positioning feature for PD98X. 

 R8.0: Added BT programming feature for PD98X. 

 R7.8: Added BT call, BT firmware upgrade and BT API features for PD98X. 

 R5.0: Added BT Call and BT firmware upgrade features are available for X1p and X1e. 

Note 

For PD6 and PD7 series, the BT call feature is performed through external BT audio accessory. 
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2. BT Call 
2.1 Introduction 
With the feature enabled, the radio transmits or receives the call through BT audio accessory. The feature 

facilitates radio operations, enhances communication imperceptibility and free hands to improve work efficiency. 

2.2 Restrictions 
 The feature is available only for PD98X/X1e/X1p. Other radios need to connect to an external BT audio 

accessory to perform BT call. 

 After the radio is connected to a BT audio accessory, it inputs or outputs the voice through the accessory, and 

is not affected by the configurations of its speaker and microphone. 

 When the radio is connected with the BT audio accessory: 

 Principle of speaker switching: The vioce will be first switched to BT earpiece. You can also press the 

programmed key of BT Audio Switch to switch the speaker. 

 Principle of microphone switching: follow PTT. When you press PTT key of the BT accessory, the BT 

microphone is enabled. When you press PTT key of the radio, the switching principle is subject to the 

microphone configuration. 

 To ensure the call quality, the distance between the radio and the BT audio accessory should be: 

 PD98X: within 10 meters 

 X1p and X1e: within 3 meters 

 PD6 and PD7 series: within 5 meters 

2.3 Configuration and Operation 
Before using the feature, you need to enable the BT feature of the radio. Only after the BT feature is enabled can 

you connect the radio to the BT audio accessory to transmit or receive the call. The BT feature is enabled through 

CPS. Different radios require a different version of CPS. 

 PD98X: R7.8 or above CPS 

 X1p and X1e: R5.0 or above CPS 

BT feature configuration and pairing method vary from models. This chapter introduces them respectively. For 

better configuration, you can also refer to the Help for details. 

Note 

No configuration is required for PD6 and PD7 series. Just connect them to an external BT audio accessory. For 

details, see chapter 2.3.3 PD6 and PD7 series. 
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2.3.1 PD98X / X1p 

Operations for PD98X are the same as that for X1p. PD98X Conventional (firmware version R8.5) is taken as the 

example to introduce how to configure the BT feature and pair with the BT audio accessory. Operations for the 

XPT Trunking radio are introduced in note. 

Configure BT Parameters 

Step 1 Enable the BT feature, and configure related parameters. 

CPS Path: Common -> Accessories -> BT 

Parameters: BT, BT Always Discoverable and Device Name. Refer to CPS Help for the parameter 

description. 

 

Note 
With the BT option checked, the BT feature is automatically enabled when the radio is turned on. 

Step 2 (Optional) Configure “BT” menu if you want to enable or disable the BT feature through radio menu. 

Configuration Path: Conventional -> General Setting -> Menu -> Common Menu -> Accessories -> 

BT. 

Parameters: Accessories and BT. Refer to CPS Help for the parameter description. 

 

Note 
For radios in XPT Trunking mode, the path is XPT Trunking -> General Setting -> Menu -> 
Common Menu -> Accessories -> BT. 

Step 3 (Optional) Configure the programmable key if you want to enable or disable the BT feature via the key. 

Configuration Path: Conventional -> General Setting -> Buttons. 

Parameters: BT. Take SK1 Short as the example. 
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Note 
For radios in XPT Trunking mode, the path is XPT Trunking -> General Setting -> Buttons. 

Step 4 (Optional) Configure the programmable key if you want to switch the audio output between BT earpiece 

and radio via the key. 

Configuration Path: Conventional -> General Setting -> Buttons. 

Parameters: BT Audio Switch. Take SK2 Short as the example. 

 

Note 
For radios in XPT Trunking mode, the path is XPT Trunking -> General Setting -> Buttons. 

Connect to the BT Devices 

After CPS configuration, please connect the BT audio accessory to the radio as follows:  

Caution: 

Before the connection, please ensure both the radio and BT audio accessory are with sufficient power. 

Otherwise, it may cause the failure during pairing or connecting.  

Step 1 Turn on the radio. 

Step 2 Enable the BT feature of the radio. 

 If the BT parameter is configured (Step 1 in section 2.3.1), the BT feature is automatically enabled 

when the radio is turned on. 

 If the “BT” menu is configured (Step 2 in section 2.3.1), you can enable the BT feature through 

radio menu by going to “Accessories -> BT -> On/Off”. 

 If the programmable key is configured with BT feature (Step 3 in section 2.3.1), you can enable the 

BT feature through the key. 

When the BT feature is enabled, the icon appears on radio screen. 

Step 3 Turn off other BT device that is connected with the radio. 

Step 4 Turn on the BT audio accessory to be connected and make it enter the pairing status. 
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Please refer to the corresponding manual for the detailed operations. Operations for Hytera BT audio 

accessory to enter the pairing status are as follows: 

 Wireless Ring PTT:  

Long press “+” and “–” keys at the same time until its LED indicator stays in blue. 

 Wireless Earphone: 

 ESW01: Long press PTT key until its LED indicator flashes alternatively in red and blue. 

 EHW02: Long press Multi-functional key until its LED indicator flashes alternatively in red and 

blue. 

 Wireless remote speaker microphone (applies to mobile radio): 

Long press On/Off key on it until the LED indicator flashes blue. 

Step 5 Pair and connect to BT audio accessories. 

The following two methods can be used for paring and connection. 

 Automatically 

1.  Go to “Accessories -> BT -> Paired Devices -> Search BT Devices” on radio menu. 

All detected BT devices appear on radio’s screen. 

 

Note 
 For PD98X of R7.8 and X1p, go to “Accessories -> BT -> Paired Devices -> Search 

PTT” or “Accessories -> BT -> Paired Devices -> Search Headset”. 
 For R8.5 or above X1p, if it already connects with a BT audio accessory and searches for 

the same type of BT accessories, “Device Connected” pops up on the screen. 

2.  Select the BT audio accessory to be connected, and then select Connect. 

The radio prompts “Connect Success” on the screen. When the radio is successfully connected 

with the BT audio accessory, the icon appears on the top left of the screen. 

 Wireless Ring PTT: LED indicator flashes in blue. 

 Wireless Earphone: 

 ESW01: LED indicator flashes in blue with the alert tone “Handset connected”. 

 EHW02: LED indicator flashes in green with the alert tone “Handset connected”. 
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 Wireless remote speaker microphone (applies to mobile radio): LED indicator flashes in blue 

rapidly and an alert tone is given. 

After the successful connection, the radio receives and transmits the calls through the BT audio 

accessory. 

Note 
If the BT audio accessory is successfully paired and connected to the radio, when it’s turned 
on next time, it will automatically connect to the radio. 

 Manually 

1.  Go to “Accessories -> BT -> Manual Match” on radio menu. 

   

2.  Select the BT device to be connected (e.g., earphone), input its MAC address, and then select 

Confirm. 

When the radio is successfully connected with the BT audio accessory, the icon appears on 

the top left corner of the screen. 

   

Note 
Please input the 12 characters MAC address. For example, if the MAC is 
XX:XX:XX:XX:XX:XX, please input XXXXXXXXXXXX. 

2.3.2 X1e 

The radio has no display screen. You need to set a programming key with BT feature and pair the radio with BT 

audio accessory via CPS. After the BT feature is enabled (by the programming key), the radio starts to search and 

connect to the BT audio accessory that it has been successfully paired with. 

Configure the BT Feature via CPS. 

Step 1 Turn on the radio. 

Step 2 Connect the radio to PC. 
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Caution 
During the configuration, do not disconnect the radio and PC, otherwise, data loss or radio damage 
may occur. 

Step 3 Run the CPS. 

Step 4 Click  on the tool bar, or select “Program -> Read from Radio” on the menu bar. 

The Communication Port dialogue box pops up. 

 

Step 5 Select the corresponding USB port for the radio, e.g., USB 1, and click OK.  

The Read dialog box pops up. 

 

Step 6 Click OK to read data from the radio.  

After the successful reading, radio model No. appears on the top left of CPS main interface. 

Step 7 Assign a programmable key with BT feature.  

CPS Path: Conventional -> General Setting -> Buttons 

Parameters: BT. Take SK1 Short as the example. 

 

Pair the radio and the BT audio accessory 

Step 1 Select “Tools -> BT Setting” on the menu bar of the CPS. 

The Communication Port dialogue box pops up. 

Step 2 Select the corresponding USB port, and click OK to access the BT configuration interface. 
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Step 3 Select Open BT to enable the BT feature. 

Open BT turns into Close BT, and the current BT firmware version (e.g., V1.01.020) is displayed.  

 

Step 4 Turn on the BT audio accessory and make it enter the pairing status. 

See Step 4 in section 2.3.1 for the detailed operations. 

Step 5 Click Search PTT to start search for the PTT device near the radio (Wireless ring PTT is taken as the 

example. The operations for wireless headset or wireless remote speaker microphone are the same). 

All detected PTT devices are displayed in BT Device list. 
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Note 

 The name of wireless ring PTT above is for reference only. 

 When the wireless ring PTT appears in BT Device list, you can click Stop Search. 

 If you want to pair the radio with other BT devices, such as wireless headset, microphone etc., 

click Search Headset or Microphone. 

Step 6 Select the wireless ring PTT in the BT Device list. 

The radio starts to pair with the wireless ring PTT. When the following box (with the actual device 

name) pops up, it indicates that the pairing is successful. 

 

Step 7 Click OK to return to the BT configuration interface.  

“Has been connected” is displayed in the State column. 
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Step 8 Uncheck Close BT option to disable the BT feature. 

The following dialog box pops up. 

 

Step 9 Click OK, and close the BT configuration interface. 

Step 10 Click  on tool bar of the CPS, or select “Program -> Write to Radio” on the menu bar. 

The Write dialog box pops up. 

 

Step 11 Click OK to write the BT configuration into the radio. 

The radio restarts automatically to enable the BT configuration. 

Step 12 Close the CPS and disconnect the radio from the PC. 

Connect to the BT Devices 

After the pairing, please connect the BT audio accessory to the radio as follows:  

Step 1 Turn on the radio. 
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Step 2 Enable the BT feature of the radio. 

Short press the SK1 key (the programmable key with BT feature as configured in Step 7 of section 2.3.2) 

to enable the BT feature. 

When the BT feature is enabled, the LED indicator glows blue and then flashes in blue once every 3s. 

Step 3 Turn on the BT devices.  

See Step 4 in section 2.3.1 for the detailed operations. 

The radio automatically starts to search for and connect to the paired BT devices. When the radio is 

successfully connected to the BT device, the LED indicator flashes in blue every 2s. 

 Wireless Ring PTT: LED indicator flashes in blue. 

 Wireless Earphone: 

 ESW01: LED indicator flashes in blue with the alert tone “Handset connected”. 

 EHW02: LED indicator flashes in green with the alert tone “Handset connected”. 

 Wireless remote speaker microphone (applies to mobile radio): LED indicator flashes in blue rapidly 

and an alert tone is given.  

After the successful connection, the radio will receive and transmit the calls through the BT audio 

accessory. 

2.3.3 PD6 and PD7 series 

For PD6 and PD7 series, a wireless earset kit is required for the BT call. The wireless earset kit includes one 

wireless earphone and one wireless adapter. Different radio requires different wireless earset kit. 

 ESW01-N1 wireless earset kit: PD70X, PD71X, PD75X, PD78X and PD79X 

 ESW01-N2 wireless earset kit: PD60X, PD66X and PD68X 

Note 

ESW01-N2 wireless earset kit is also applicable for X1e and X1p. In this chapter, PD78X is taken as the 

example to introduce how to use the wireless earset kit. 

Step 1 Turn on the radio. 

Step 2 Connect the wireless adapter to the radio. 

Fix the wireless adapter on radio’s accessory jack by its bolt. 

If successfully connected, “Accessories Connected” appears on radio’s screen. The LED indicator of the 

wireless adapter flashes in blue. 

Step 3 Pair and connect the wireless adapter to the wireless earphone. 

The following two methods can be used for the pairing and connection. 
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 Automatically 

1.  Fit the wireless earphone into the wireless adapter and push it to the bottom. 

The wireless earphone starts to pair and connect with the wireless adapter when their LED 

indicators flash in blue and red alternatively. 

2.  Take the wireless earphone from the wireless adapter. 

The connection is completed when LED indicator of the wireless earphone flashes in blue. 

 Manually 

1.  Long press Multi-function key on the wireless earphone until its LED indicator alternatively 

flashes in blue and red. 

2.  Long press Multi-function key on the wireless adapter until its LED indicator alternatively 

flashes in blue and red. 

The wireless earphone starts to pair and connect with the wireless adapter. When LED of the 

wireless earphone flashes in blue, the connection is completed and the radio is able to 

transmit and receive the calls through the BT audio accessory. 

Note 
If the BT audio accessory is successfully paired and connected to the radio, when it’s turned on next 
time, it will automatically connect to the radio. 
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3. BT Programming 

3.1 Introduction 

The BT programming enabled radio can be wirelessly connected to PC to perform programming operations. 

A BT dongle is provided to perform the feature. The wireless programming can be realized when the radio is 

paired with the dongle. The picture below shows how the BT programming works. 

Target Radio

PC (CPS)

BT Dongle

 

3.2 Restrictions 
 Wireless programming is applicable only for PD98X with firmware R8.0 or above. 

 For better performance, please keep the distance between the radio and the BT dongle is within 5 meters. 

 One PC can perform wireless programming only for one radio at a time. 

 When the radio is connected with the BT dongle, it cannot be connected to other BT audio accessory. 

 The BT dongle must support virtual serial ports (please confirm it with the supplier). 

3.3 Configuration and Operation 
3.3.1 Preparations 

Before you start, please prepare the following items. 

 PC: Windows XP/Windows Vista/Windows 7, 32/64-bit. Windows 7 is taken as the example. 

 CPS: R8.0 or above 

 Radio with firmware R8.0 or above 

 BT Dongle 

 BT Driver: Ensure the BT driver has been successfully installed in the PC; otherwise, the PC cannot recognize 

the BT dongle. If the BT driver is not installed yet, please refer to the corresponding manual for the 

installation. 
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Note 

No matter the PC supports the BT feature or not, a BT dongle is recommended for the BT programming 

operations. BlueSoleil dongle is recommended for radios overseas. In this chapter, BlueSoleil BT dongle 

(software 10.0.494.0) is used as the example. 

3.3.2 Enable the BT Feature 

Before using BT programming, you need to enable the BT feature, and then connect the radio to the dongle. 

 If the BT parameter is configured (Step 1 in section 2.3.1), the BT feature is automatically enabled when the 

radio is turned on. 

 If the “BT” menu is configured (Step 2 in section 2.3.1), you can enable the BT feature through radio menu by 

going to “Accessories -> BT -> On/Off”. 

 If a programmable key is configured with BT feature (Step 3 in section 2.3.1), you can enable the BT feature 

through the key. 

When the BT feature is enabled, the icon appears on radio screen. 

3.3.3 Connect the BT Dongle to the PC 

Step 1 Install the BT driver on PC. 

Step 2 Run the BT driver and enter its main interface as follow. 

 

Step 3 Connect PC and BT dongle 

Insert the BT dongle into the USB port on the PC. After successfully connection, the software icon  

on the PC’s taskbar turns into . 

3.3.4 Connect the Radio to the BT Dongle 

The following two methods can be used for paring and connection. 
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By the Radio (Recommended) 

Step 1 Turn off other BT device that is connected with the radio. 

Step 2 Select “Accessories -> BT-> Paired Devices -> Search BT Devices” on radio menu. 

All detected BT devices appear on radio’s screen. 

 

Step 3 Select the hostname of the PC which the BT dongle is connected with, and then select Connect. 

On the PC, the following dialog box pops up. 

 

Step 4 Select “Always allow this remote device to use this service in my device” and then click Yes. 

“Accessories Connected” appears on radio’s screen. When the radio has been successfully connected to 

the BT dongle, the BT icon on radio’s screen turns into . 

By the BT Dongle 

Step 1 Turn off other BT device that is connected with the radio 

Step 2 Select “Accessories -> BT -> Always Detected” on radio’s screen to set the visibility of the radio. 
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Step 3 On main interface of the BT driver, double click yellow button in the middle. Or click the Menu button 

on the top right corner and select Search Devices. 

    

All detected BT devices appear on the main interface as the below picture. 

 

Step 4 Right click the radio icon (BT name of the radio is Hytera by default), and select Pair. 

After the paring is completed, “Paired” is shown on the left bottom of the main interface.  

Note 
To recognize the radio easily, you can set its BT name by going to “Accessories -> BT-> BT Devices 
Name” on radio menu. 
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Step 5 Right click the radio icon, and select Connect Booth Serial Port.  

After the connection is completed, “Connected” is shown on the left bottom of the operation interface. 

 

3.3.5 Enable BT Programming 

Step 1 Run the CPS. 

Step 2 Click  on the Tool Bar of the CPS. 

When the BT programming is enabled, the icon turns to . 

Step 3 Select “Program -> Communication Port” on the Tool Bar of the CPS.  

The following dialog box pops up. 
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Step 4 Select the BT COM that the radio is connected with, and then click OK. 

The radio is wirelessly connected to PC. You can wirelessly perform the programming operations, 

including Read, Write, Clone, Query GPS Version, Import / Export Multilanguage, Load Animation and 

Language Package. 



BT Indoor Positioning User Manual 

 

22 

 

4. BT Indoor Positioning 

4.1 Introduction 

When the radio cannot be accurately positioned through GPS indoor, you can enable the BT Location to realize 

the positioning with the indoor BT beacons. 

The BT beacon is a hardware transmitter developed based on V4.0 BT Low Engergy Technology (BLE). After 

deployed indoor, it broadcasts data packet to the radios within the communication coverage. When the radio 

detects the beacon UUID is the same as configured, it sends the UUID code and location data of the beacon with 

the strongest signal to the dispatch station. The dispatch station reverts the code to UUID and sends the UUID and 

location data to the PC. Then the dispatcher can view the real-time location of the radio and make effective on-site 

dispatch. 

Compared to GPS, BT beacon is easy to deploy for indoor use and power saving. You can also use a third-party 

software to visualize the radio locations on the map. 

The figure below shows how the BT Location works. 

BT Beacon

BT Beacon
BT Beacon

Control Center

Target Radio

Beacon Info

Third-party 
Software

 

4.2 Application 

The BT Location makes up the shortage of GPS positioning and can be applied to vavious indoor scenes, such as 
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positioning of factory workers, power plant inspectors, tunnel workers, high-speed train staff, prison staff, 

warehouse forklifts, smart buildings and robot. 

4.3 Restrictions 

 The BT Location is applied to PD98X with firmware R8.5 or above. 

 The BT Location is a paid feature. 

 The BT beacons need to be well deployed indoor. For more information, please contact Hytera. 

 The BT Location and BT API features (e.g., BT programming) cannot be used at the same time. During 

programming, debugging or scanning, the radio cannot transmit the BT location data. 

 During voice or data transmission, the radio does not respond to the system request to report the BT location 

data until the transmission is completed. 

 In XPT mode, if a radio is used to dispatch services, the BT location data is transmitted through voice repeater; 

while if a repeater, data repeater or voice repeater. 

4.4 Configuration 

4.4.1 Radio Configuration 

Step 1 Activate the BT location feature. 

The BT Location feature is a paid feature. A license is required to activate this feature. For operations, 

refer to DMR Radio_Authorization_Operation Guide. 

Step 2 Enable the BT feature. 

 If the BT parameter is configured (Step 1 in section 2.3.1), the BT feature is automatically enabled 

when the radio is turned on. 

 If the “BT” menu is configured (Step 2 in section 2.3.1), you can enable the BT feature through 

radio menu by going to “Accessories -> BT -> On/Off”. 

 If the programmable key is configured with BT feature (Step 3 in section 2.3.1), you can enable the 

BT feature through the key. 

When the BT feature is enabled, the icon appears on radio screen. 

Step 3 Enable the BT location feature and configure related parameters. 

CPS Path: Conventional -> General Setting -> Accessories -> BT Location. 

Parameters: BT Location, Location Info Priority, Button, Power On, Power Off, Time and Report 

Interval Time. Refer to CPS Help for the parameter description. 
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Note 
For radios in XPT Trunking mode, the path is XPT Trunking -> General Setting -> Accessories -> 
BT Location. 

Step 4 Configure Beacon Info list. 

CPS Path: Common -> Accessories -> BT Location. 

Parameters: Alias, UUID and UUID Code. Refer to CPS Help for the parameter description. 

 

Note 

 You can import or export the beacon information in batch by selecting “Tools -> Import/Export 

Beacon Info” on the menu bar of CPS. 

 When a radio (portable or mobile) is used to dispatch services, its “Beacon Info” must be 

configured the same as that of other radios. 

Step 5 Configure Control Center ID, Location Port and Identifier. 

CPS Path: Conventional -> General Setting -> Network -> Radio Services. 

Parameters: Control Center ID, Location Port and Identifier. Refer to CPS Help for the parameter 

description. 

 

Note 
For radios in XPT Trunking mode, the path is XPT Trunking -> General Setting -> Network -> 
Radio Services. 
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Step 6 Configure Location Info Revert Channel. 

The radio may fail to report the location data on the current channel if it is occupied by other radios 

transmitting voice or data signals. To ensure the timeliness, it is recommended that you choose one 

dedicated channel to transmit the BT location data. 

CPS Path: Conventional -> Channel -> Digital Channel -> Tx. 

Parameters: Location Info Revert Channel. Refer to CPS Help for the parameter description. 

 

Note 

 For radios in XPT Trunking mode, Location Report Type should be set as “Normal”. CPS Path: 

XPT Trunking -> Channel -> XPT Personality -> Per XN -> Miscellaneous. 

 If RX Only is selected, the radio will be unable to transmit the BT location data. 

Step 7 Enable Voice with Location Info feature. 

If disable, the radio will not report the location data to the dispatch station when you initiates a call by 

PTT. As a result, the dispatcher cannot obtain the real-time location of the radio. It is recommended that 

you enable the Voice with Location Info feature and configure the way the radio reports the location 

data. 

CPS Path: Conventional -> General Setting -> Accessories -> Voice with Location Info. 

Parameters: Voice with Location Info, PTT or Time. Refer to CPS Help for the parameter description. 

 

Note 
For radios in XPT Trunking mode, the path is XPT Trunking -> General Setting -> Accessories -> 
Voice with Location Info. 

Step 8 Enable In Call Location Revert feature. 

If disable, the radio transmits the location data after the voice is received. As a result, the dispatcher 

cannot obtain the real-time location of the radio. It is recommended that you enable the In Call Location 

Revert feature. 

CPS Path: Conventional -> Digital Common -> Basic -> Miscellaneous. 

Parameters: In Call Location Revert. Refer to CPS Help for the parameter description. 
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Note 
For radios in XPT Trunking mode, the path is XPT Trunking -> Digital Common -> Basic -> 
Miscellaneous. 

Step 9 (Optional) Configure BT location menu if you want to enable or disable the feature via radio menu. 

CPS Path: Conventional -> General Setting -> Menu -> Common Menu -> Accessories. 

Parameters: Accessories, BT and BT Location. Refer to CPS Help for the parameter description. 

 

Note 
For radios in XPT Trunking mode, the path is XPT Trunking -> General Setting -> Menu -> 
Common Menu -> Accessories. 

Step 10 (Optional) Configure a programmable key with BT location report feature. 

After the configuration, when you press this key, the radio will transmit the BT location data to the 

dispatching center. 

CPS Path: Conventional -> General Setting -> Buttons. 

Parameters: BT Location Report. SK2 Short is taken as the example. 

 

Note 

 For radios in XPT Trunking mode, the path is XPT Trunking -> General Setting -> Buttons. 
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 The BT Location Report option is available only when Button option is selected. See Step 3 in 

section 4.4.1. 

4.4.2 Repeater Configuration 

Step 1 Configure Beacon Info list of the repeater if the repeater is used to dispatch service. 

CPS Path: Conventional -> General Setting -> Accessories -> Beacon Info. 

Parameters: UUID and UUID Code. Refer to CPS Help for the parameter description. 

 

Note 

 For radios in XPT Trunking mode, the path is XPT Trunking -> General Setting -> Accessories 

-> Beacon Info. 

 The “Beacon Info” must be configured the same as that of the radio. Otherwise, the repeater will 

not be able to correctly revert the UUID code to the UUID. 

Step 2 Configure Radio GPS Slot Port and GPS Port Identifier, because the repeater forwards BT location data 

of the radio through the GPS Slot Port. 

CPS Path: Conventional -> General Setting -> Network -> Application Programming Interface. 

Parameters: GPS Port Identifier, Radio GPS Slot1 Port, or Radio GPS Slot2 Port. Refer to CPS Help 

for the parameter description. 

 

 

Note 
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 When the repeater is used to dispatch service, its Radio GPS Slot Port must be the same as 

Location Port of the radio. Otherwise, the repeater cannot forward the beacon information of 

the radio. 

 The above parameters are available only when Forward to PC is selected. 

4.5 Radio Operation 

4.5.1 Radio Menu 

If the BT Location menu is configured (Step 9 in section 4.4.1), you can enable or disable the BT location feature 

and view the beacon information through radio menu: 

 Menu -> Accessories -> BT Location -> On/Off 

 Menu -> Accessories -> BT Location -> Beacons Info 

 

Note 

Please enable the BT feature before using the BT location feature. 

4.5.2 Programmable Key 

If a programmable key with BT location feature is configured (Step 10 in section 4.4.1), when you press this key, 

the radio will transmit the BT location data to the dispatching center. 
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5. BT Firmware Upgrade 

5.1 Introduction 
The BT firmware can be upgraded through third-party software to fixe firmware bugs, improve BT performance 

and enhance stability.  

5.2 Restriction 
The upgrade is only applied to the radio with in-built BT module. 

5.3 Upgrade and After-upgrade Check 
Before the upgrade, please check BT firmware version of the radio. The version information is used to check 

whether the upgrade is successful. This chapter describes how to upgrade the BT firmware from V2.01.003 to 

V2.01.008. 

5.3.1 BT Firmware Version Check 

Step 1 Turn on the radio 

Step 2 Connect the radio to PC. 

Step 3 Run the CPS. 

Step 4 Select “Tools -> BT Setting” on the menu bar of the CPS. 

The Communication Port dialogue box pops up. 

 

Step 5 Select the corresponding USB port, and click OK to access the BT configuration interface. 



BT Firmware Upgrade User Manual 

 

30 

 

 

Step 6 Select Open BT. 

Open BT turns into Close BT, and the current BT firmware version (e.g., V2.01.003) is displayed.  

 

Step 7 Uncheck Close BT option. 

The following dialog box pops up. 

 

Step 8 Click OK, and close the BT configuration interface. 
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Step 9 Close the CPS and disconnect the radio from the PC. 

5.3.2 Preparations 

Before you start, please prepare the following items. 

 PC: Windows XP/Windows Vista/Windows 7, 32/64-bit. Windows 7 is taken as the example. 

 BT Driver: Ensure the BT driver has been successfully installed in the PC; otherwise, the PC cannot recognize 

the BT dongle. If the BT driver is not installed yet, please refer to the corresponding manual for the 

installation. 

 Programming Cable: 

 PD98X: PC38 

 X1p and X1e：PC45 

 USB Driver: Ensure the USB driver has been successfully installed on PC; otherwise, the PC cannot recognize 

the radio. If not installed yet, please refer to Digital USB Driver Installation Guide R5.0 for the installation. 

 BT firmware upgrade software: Ensure the software has been successfully installed on PC. It’s recommended 

to use BlueSuiteSource for the upgrade. 

5.3.3 Firmware Upgrade 

Disable the BT feature and make the radio enter the BT upgrade mode before upgrade.  

Step 1 Disable the BT feature. 

 If the BT parameter is configured (Step 1 in section 2.3.1), you can disable the BT feature only 

through CPS. 

 If the “BT” menu is configured (Step 2 in section 2.3.1), you can disable the BT feature through 

radio menu by going to “Accessories -> BT -> On/Off”. 

 If the programmable key is configured with BT feature (Step 3 in section 2.3.1), you can disable the 

BT feature through the key. 

When the BT feature is disabled, the icon disappears on radio screen. 

Step 2 Turn off the radio. 

Step 3 Connect the radio to PC 

PD98X as the example, the connection diagram is shown as below. 
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PC38 Programming Cable

 

Step 4 Hold TK and SK1 keys, and then turn on the radio. 

When the radio enters the BT upgrade mode successfully, “BT Upgr Mode” displays on radio screen. 

Otherwise, it fails. In this case, please turn off the radio and repeat the above operations. 

Step 5 Run the firmware upgrade software. 

Step 6 Click Refresh to refresh the port information. 

 

Step 7 Select the corresponding port for the radio, e.g., COM6, and click Start.  
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The upgrade is successful if the following dialog box appears. If it prompts “Upgrade Failed”, please 

retry according to the instructions in the dialog box. 

 

Step 8 Click Exit to exit the software. 

Step 9 Turn off the radio to exit BT upgrade mode. 
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5.4 After-upgrade Check 
Please check whether the BT firmware has been upgraded to the latest (e.g., V2.01.008) according to 5.3.1 Check 

BT Firmware Version. If not, please check whether the version of the software meets the requirements, and if yes, 

please make radio enter the BT upgrade mode and try again.
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6. BT API 
Hytera provides third party with BT API (application programming interfaces) for more applications, including 

online radio status management, text messages, call controls, radio register service. 

The BT API is applicable only for PD98X. For details, please refer to Hytera DMR Peripheral Equipment 

Development Overview and Hytera DMR Peripheral Equipment Development Guide. 
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7. FAQ 
Q: How to handle the disconnection due to unexpected power-off of the radio or BT device? 

A: This issue can be solved as below: 

 For BT device 

Restart the BT device. The device will automatically connect to the last radio it connected. 

 For the radio 

1. Restart the radio and enable BT feature.  

2. Restart the BT device. The device will automatically connect to the last radio it connected. 

 

Q: Why does the radio fail to search the BT device? 

A: The BT device is not turned on or not in the pairing status. 

 

Q: Why does the BT device fail to enter the pairing status? 

A: The ways to enter the paring status vary from BT devices. Please refer to the corresponding manual for the 

detailed operations. 

 

Q: Why does radio fail to connect to the BT device? 

A: The causes may be: 

 The BT device is out of connection range. 

 The BT device was not successfully connected to the radio before. Please retry to pair and connect them.  

 The BT device connects to the last radio or other device that it connected. Refer to the corresponding 

manual for the operations. 

 If the solutions above don’t work, please restart the BT device. 

 

Q: When the radio connects to the BT dongle, why does the driver repeatedly prompt “Device Connected” or 

“Device Disconnected”? 

A: The PC name is more than 10 characters. Go to “Start -> Control Panel -> System and Security -> System”, 

and modify the name.
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Abbreviations 
Abbreviations Full Name 

API Application Programming Interface 

CPS Customer Programming Software 

DMR Digital Mobile Radio 

EDR Enhanced Data Rate 

GPS Global Positioning System 

HFP Hands-Free Profile 

SPP Serial Port Profile 

XPT Extended Pseudo Trunk 
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